This release fixes a bug in the new AssertJ 3.x module.

path: /en/oss/XMLUnit | #

The only real change when compared to XMLUnit for Java 2.8.0 is the introduction of a new xmlunit-assertj3 module that requires AssertJ 3.18.1 or later in order to address a problem with running AssertJ tests in an OSGi environment.

The original xmlunit-assertj module will still be supported.

The full changelog of XMLUnit for Java 2.8.1:

path: /en/oss/XMLUnit | #

Both releases are mostly bugfix releases. Unfortunately both are going to break backwards compatibility for some people.

All modules of XMLUnit for Java now require Java7 as a minimum and the optional JAXB dependency has been updated to use the Jakarta XML Binding API. XMLUnit.NET has made ISource disposable which is going to break custom implementations.

Details for XMLUnit for Java 2.8.0

Details for XMLUnit.NET 2.9.0

path: /en/oss/XMLUnit | #

Welcome to your new home.

path: /en/personal/family | #

These two releases contain an incompatible change to the (I)PlaceholderHandler interface, thus the new minor versions. The Evaluate method now receives a variable number of string arguments in addition to the textual content of the element/attribute. This allows placeholders like ${xmlunit.matchesRegex(some\s*regex)}.

For XMLUnit.NET only the placeholders package has changed, for Java in addition the assertj module is now supposed to be compatible with AssertJ 3.15+.

Release Notes for XMLUnit for Java 2.7.0:

Release Notes for XMLUnit.NET 2.8.0:

path: /en/oss/XMLUnit | #